Problem with gallery addon

Mariano Martinez Peck marianopeck at
Wed Jun 10 20:01:45 CEST 2009

Today, I test it again in another windows machine and I have another
problem. When saving the uploaded zip file, I have the following error:

"Error: Fotos/foto_flor.jpg is an invalid child in Galeria."

Suppose my file is called "" and I have a photo inside called

After debugging for a while, this is the problem. ZipArchive generates a
member with fileName 'fotos/foto_flor.jpg'. Then when trying to addPictura a
validation is done:

and when it does:

aString allSatisfy: [ :char | self validCharacters includes: char ]

In this case, aString is 'fotos/foto_flor.jpg' and '/' is not in

So, what can I do?

1) add '/' to self validCharacters  ?  I think this has a lot of impact in
other places

2) in PGImportArchiveCommand>>addPicture: archiveMember
remove the  '/' when creating the picture (PGPicture) object

what should I do? any other idea?



On Wed, Jun 10, 2009 at 2:46 PM, Damien Cassou <damien.cassou at>wrote:

> On Wed, Jun 10, 2009 at 5:42 PM, Mariano Martinez
> Peck<marianopeck at> wrote:
> > I can also debug it and see what the problem is. I just ask because
> perhaps
> > this was a known problem or someone has already faced it.
> I tried it and it worked for me at that time. Please tell me if there
> is something wrong in my code.
> --
> Damien Cassou
> "Lambdas are relegated to relative obscurity until Java makes them
> popular by not having them." James Iry
> _______________________________________________
> Magritte, Pier and Related Tools ...
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the smallwiki mailing list